Debian

Installation des Steam-Clients auf Debian Jessie 8 Linux Top 10-Bit

Installation des Steam-Clients auf Debian Jessie 8 Linux Top 10-Bit

Dieser Artikel beschreibt eine Installation des Valve Steam Linux -Clients auf Debian 8 Jessie 64bit. In dem Artikel geht davon aus, dass Sie Ihre VGA -Laufwerke bereits installiert haben. Beginnen wir mit Steam Client Download:

$ wget http: // Media.dampfbetrieben.com/client/installer/Steam.Deb 

Sobald Sie den Client heruntergeladen haben, installieren Sie die Dampf.Deb Paket. Bitte nicht der folgende Befehl erfordert Root -Berechtigungen und zeigt Fehler aufgrund der Abhängigkeitsprobleme an, die wir als nächstes beheben werden:

# DPKG -I -Dampf.Deb auswählen, die zuvor nicht ausgewählte Paket-Steam-Leiter ausgewählt haben. (Lesen der Datenbank… 82762 Dateien und Verzeichnisse derzeit installiert.) Vorbereitung auf das Auspacken von Dampf.Deb… Dampf-Leiterpackungspacken (1.0.0.49)… DPKG: Abhängigkeitsprobleme verhindern die Konfiguration von Dampf-Leuchther: Steam-Launcher hängt von Curl ab; Allerdings: Package Curl ist nicht installiert. Der Dampf-Lauger ist auf Zenity abhängig; Allerdings: Paketzenity ist nicht installiert. DPKG: Fehlerverarbeitungspaket Steam-Leiter (-Installation): Abhängigkeitsprobleme-Unkonfigurierte Verarbeitungsauslöser für MIME-Support (3.58)… Verarbeitungsauslöser für Hicolor-Icon-Theme (0).13-1)… Verarbeitungsauslöser für Man-DB (2.7.0.2-5)… Es wurden Fehler bei der Verarbeitung aufgetreten: Dampf-Leuchther 

Jetzt werden wir alle Abhängigkeiten installieren, die zur Installation des Steam -Clients erforderlich sind:

# APT -Get -f Installation 

Der obige Befehl sollte den Steam -Client erfolgreich auf Ihrem System installieren. Um den Steam-Client auszuführen, müssen Sie jedoch zunächst einige weitere 32-Bit-Bibliotheken installieren. Dafür müssen wir Multi-Archs aktivieren:

# DPKG --Add-Architecture i386 # APT-Get Update 

Installieren Sie als nächstes alle erforderlichen 32 -Bit -Bibliotheken:

# APT-Get Install libgl1-mesa-dri: i386 libgl1-mesa-glx: i386 libc6: i386 

Abhängig von Ihrer Grafikkarteninstallation müssen Sie möglicherweise binäre OpenGL 32-Bit-Bibliotheken installieren. Andernfalls sehen Sie eine Fehlermeldung, wenn Sie versuchen, den Steam-Client zu starten:

Ihnen fehlen die folgenden 32-Bit-Bibliotheken, und Steam kann nicht ausgeführt werden: libgl.So.1 

Um dieses Problem zu beheben, müssen wir OpenGL 32-Bit-Bibliotheken installieren, die für unseren VGA-Typ geeignet sind:

NVIDIA: # APT-Get Installieren Sie libgl1-nvidia-glx-i386 ATI/AMD: # APT-Get Install libgl1-fglrx-glx-i386 

Sie matten jetzt Ihren Steam -Client:

$ Steam 


GRUB -Ladung Stufe 1.5 Fehler Top 10
GRUB -Ladung Stufe 1.5 Fehler 15 Die Fehlermeldung zeigt nicht unbedingt an, dass Sie einen MBR (Master -Boot -Datensatz) Ihres Bootings zerstört habe...
Zeigen Sie die Google -Suchergebnisse aus unterschiedlichen Gegenständen an
In vielen Fällen habe ich versucht, nach Schlüsselwörtern zu suchen und ein Ergebnis zu erhalten, das ein Land ist, das nicht das ist, nach dem ich su...
Joomla - Fehler Die vom Server zurückgegebene XML -Antwort ist ungültig
Heute hatte ich ein Problem, eine Joomla 1 zu installieren.5 auf meinem VPS -Server. Tatsächlich konnte ich es installieren, aber ohne Beispieldaten. ...